LibreOffice 4.3.1

LibreOffice logó A The Document Foundation bejelentette a LibreOffice 4.3-as, „friss” sorozat első hibajavító kiadását, a LibreOffice 4.3.1-et, amely több mint 100 hibát javít, köztük két CVE-számmal ellátott biztonsági problémát is. A biztonsági problémák javítását a 4.2.6-os verzió is soron kívül megkapta, abból is elérhetők az új binárisok 4.2.6-secfix néven. Minden LibreOffice-felhasználónak javasolt a frissítés, azoknak is, akik az augusztus 5-én megjelent LibreOffice 4.2.6-ot használják.

A LibreOffice 4.3.1-ben javított hibák listája két részletben érhető el: RC1 és RC2. A LibreOffice 4.3.1-ben és 4.2.6-ban javított biztonsági hibák a következők voltak:

  • CVE­-2014­-3524 “CSV Command Injection and DDE formulas”
  • CVE­-2014­-3575 “Arbitrary File Disclosure using crafted OLE objects”

A LibreOffice 4.3.1 és a LibreOffice 4.2.6 a berni LibreOffice konferencián élőben is be fog mutatkozni szeptember 3. és 5. között. A konferencia programjában rengeteg előadás szerepel a fejlesztés, közösség, marketing és migráció témájában. Az angol nyelvű előadások mellett lesz egy német szekció is, amely az ausztriai, németországi és svájci közigazgatási és vállalati nyílt forrású projektekről fog szólni.

“LibreOffice 4.3.1” bejegyzéshez 9 hozzászólás

  1. 4.2.6-secfix

    Ajaj!

    Nem az a baj, hogy javítottak egy csúnya hibát, még az se olyan nagy baj, hogy létezett a hiba, de miért kell egy újabb verziószámozást (jelölést bevezetni? Miért nem lehetett “4.2.7”-es verzió ez a javítás, és legfeljebb az életciklus egy verziószámmal megnőtt volna…
    Ha így fogják számozgatni, jelölgetni a verziók al-verzióinak egyszer-kétszer-többször foltozott darabjait, akkor ember legyen a talpán aki követni tudja majd, hogy melyiket is célszerű használnia. (Nem mindenki innen a híroldalról jut el a letöltési oldalra…)

    1. A -secfix csak a letöltendő csomag neve. A belső verziószám 4.6.2.3. A 4.2.7 más, azzal is megzavarták volna az embereket. És mivel a 4. számot nem szokták kiírni, maradt ez a megoldás.

  2. Ha már verziószám: az NVDA (NonVIsual Desktop Access) képernyőolvasó verziószáma irányadó példa lehet, ahol a stabil verziók két tagból állnak: az évből, törve a verziószámmal, például: 2014.2. A nem stabil verziók ellenben valamilyen ötjegyű, folyton növekvő verziószámot kapnak, illetve láttam például háromezer-valahányszázast, most meg tizenegyezer-valahányszáznál jár, folyton növekszik. Így a stabil és a fejlesztői verziók a verziószámozással is jól elkülöníthetők.
    A módszer bevezetésére pont azért volt szükség, mert egyre nagyobb káosz alakult ki a számozás körül.
    Persze az NV Access Org. kis szervezet, lehet, hogy a saját útját követte, ellenben biztos vannak már erre szabványos megoldások. Ugyanakkor praktikusnak tűnik ez a megoldás.

  3. A Letöltés oldalon szerepeltettek egy linket a Portable változat beszerzésének megkönnyítéséhez. A belinkelt változat azonban a Normal, ami NEM tartalmazza a magyarítást. Érdemes lenne a másik (All Languages) csomagot belinkelni, hogy az érdeklődők és potenciális felhasználók ne bosszankodjanak a magyarítás nélküli csomag miatt.
    Segítségeteket előre is köszönöm.

    1. Köszönöm szépen, jeleztem Andrásnak is a hibát!

      A helyes hivatkozás a http://download.documentfoundation.org/libreoffice/portable/4.3.1/LibreOfficePortable_4.3.1_MultilingualAll.paf.exe

      És telepítés után az Eszközök‣Beállítások‣Nyelvi beállítások‣Nyelvek‣Felhasználói felület pontban lehet a magyar felületet beállítani, mivel valamiért a telepítő nem kínálja fel a magyar nyelvet.

      A http://portableapps.com/apps/office/libreoffice_portable/ oldal valóban tartalmazza a cikkben említett 4.2.6 utolsó hibajavító kiadását is, amely a napi használatra sokkal inkább javasolható:

      http://download.documentfoundation.org/libreoffice/portable/4.2.6/LibreOfficePortablePrevious_4.2.6-secfix_MultilingualAll.paf.exe

  4. 4.2.5 az utolsó, amit használni tudok
    4.3 egyáltalán nem nyitható meg
    4.3.1 beindul, de félúton meggondolja magát, és ezt az üzenetet kapom:
    Exctension Manager: cannot terminate an externally created thread

    telepítve és hordozható változatban is-
    Bár XP-t használok, de a rendszerkövetelmények szerint ez nem szabadna, hogy problémát jelentsen
    semmi olyan nincs a gépemen, ami zavart okozhat

    1. Kedves Katalin!

      Sajnos nem találtam hasonló hibajelzést a bejelentett hibák között, de elképzelhető, hogy a felhasználói könyvtár ideiglenes átnevezése, vagy végleges eltávolítása megoldja a problémát, ez a

      C:Documents and Settings[felhasználó]Application DataLibreOffice

      a portable esetében pedig

      LibreOfficePortableDatasettings

      Mivel a kiterjesztéskezelő panaszkodik, talán egy félig telepített, vagy régi kiterjesztés miatt (bár ezeket a portable változat alapból nem veszi át a leírás szerint).

Hozzászólás a(z) Andras Timar bejegyzéshez Kilépés a válaszból

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük